Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 01, 2025 - 07:00 UTC
Scheduled
The PointPerfect Flex service in North America will undergo regular maintenance on July 1st 2025 between 07:00 UTC and 09:00 UTC. Customers connected with the service in North America might experience some short disruptions in the service.
Posted Jun 30, 2025 - 10:21 UTC
This scheduled maintenance affected: PointPerfect Flex, Localized RTCM Corrections (North America), PointPerfect Flex, Continental corrections (MQTT service, North America, L-Band service, North America), and PointPerfect Flex, Localized SPARTN Corrections (United States).